Loading...

Community Script Hook V .NET 2.9.4

Download
Community Script Hook V .NET is an ASI plugin, which allows running scripts written in any .NET language ingame. It's full source code is hosted on Github (Changelog). Development is community-driven and open to everybody, so contributions are warmly welcomed.

Press the "Insert" key to reload scripts. This key can be changed in the accompanying INI file.

Installation
  1. Install both the Microsoft .NET Framework 4.5.2 (or higher, so skip this on Windows 10) and the Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64).
  2. Download and install the latest Script Hook V.
  3. Download Community Script Hook V .NET and copy the ASI file into your game directory (The DLL and XML files are for developers only).
View topic on GTAForums »
First Uploaded: April 27, 2015
Last Updated: December 18, 2016
Last Downloaded: 20 seconds ago
1,489,328

Sponsored Link

1,534 Comments

  • Default

    @nightjay0044 did you have any problems?

    5 days ago
  • 4c336a photo

    @ilkkaSAURUS, no problems just had to reinstall a few mods cuz they updated theirs too. thats it though.. all works good..with script hook v & .net now

    5 days ago
  • Default

    @ilkkaSAURUS ı think it wont take more than 3 days also i installed all superhero scripts,lots of addons,4-5 trainers and batman cars pack and ı should upload videos to youtube

    5 days ago
  • Default

    I confirm no problems after reinstalling Script Hook V, Community Script Hook V, and these mods: VisualV, Open All Interiors and Single Player Apartment. All working fine. Thank you very much, modders!

    5 days ago
  • Default

    @agatipoullos What mine crashes when I click single player

    5 days ago
  • Default

    @CptMemu Have you reinstalled the mods in a clean GTA V installation? That was what I did and it works for me. If fact I have just being playing with Single Player mod, and I could buy apartments, park cars in their garages... all worked fine.

    5 days ago
  • 226131 ghil icon

    The last update doesn't break any mod compatibility. You can use mods requiring Script Hook V only by updating SHV.

    5 days ago
  • Aca807 bluelade picture (cartoon character)

    Please get this updated!

    5 days ago
  • Default

    @Bluelaade it doesn't need to be updated. If you're game is not loading, it's not this plugin.
    After reading the comments of others regarding this plugin, I did the same thing as a clean install basically, but for the Redux Mod.
    I was running the Redux Mod along with some custom cars, and handling config.
    For anyone who was running the redux mod, and came here thinking this is why it's not loading, do this.
    1 -I backed up my handling.meta and dlclist.xml from the update.rpf in my mods folder. (if you're game was vanilla except for the redux mod, you won't need to do this)
    2nd (and this part relates specifically to the Redux Mod) Since the redux mod requires you to copy update folder, common.rpf, x64a.rpf, and x64w.rpf from the game folder to the mod folder, I figured the update changed some of those files, so I copied them again so it would copy the updated files from the latest patch.
    3 -Installed the Redux Mod as Normal, and then the redux patch.
    4 -Put my custom handling.meta and dlclist.xml back in the update.rpf of the mod folder. Loaded right up.

    4 days ago
  • Default

    can confirm this mod still works after the recent patch :)

    4 days ago
  • Jimmy

    this needs to update!!

    4 days ago
  • Default

    update needed!
    .
    .
    .
    .

    3 days ago
  • 3696bc m3rkster

    i do have problems with this it does not reload scripts when i press the insert but i can confirm that this does work just not the reload scripts bit i have tryed all sorts to get the reload key to work i.e. reinstalling gta removing the mods folder and try ScriptHookVDotNet alone to see if i had conflicting problems but didn't work lol.

    3 days ago
  • Gtao56

    for some reason (and im not complaining) you don"t need to wait for script hook v dot net to update because this old version works with the new version of script hook v

    3 days ago
  • Trevor3

    @2432EWS nope,it's doesn't work

    2 days ago
  • Gtao56

    @MatteSdC it worked for me so i dont know what you did wrong

    2 days ago
  • Default

    So are there no updates for this anymore? Because the current version doesn't work! The .asi file doesn't even get recognised! Are there any alternatives to this? Because without this, I don't think I can use ANY script mods anymore!
    Please help

    1 day ago
  • Default

    Is it possible to use two mods at same time? I know stupid question :)

    1 day ago
  • 3696bc m3rkster

    ok i can confirm that this does still work for me i forgot the .ini at first that was the reason i couldn't reload lol @GetA Life117 this does work i use ScriptHookVDotNet v2.9.4 dont forget the .ini

    23 hours ago
  • Default

    @m3rk thanks for the tip I knew there was something missing. But I downloaded it twice now and there is no .ini file. Where am I supposed to get it from?
    Now I used one from a previous release and it still doesn't work!
    Why is it not working? My game was recently fresh installed so there should be no way that there is something conflicting with it. The asi-loader works perfectly, since I can use a trainer, so the problem has to be with ScriptHookVDotNet.
    Seeing how this doesn't work on a freshly installed version of gta v, it's most likely due to the fact that this mod is outdated. And if that is the case my final question is: Why hasn't this been updated since december and why is there no alternative for ScriptHookVDotNet?

    11 hours ago
Join the conversation! Log In or register for an account to be able to comment.