Loading...

Speedometer 1.2.4b

Download
LeFix
LeFix Speedometer
-development stopped-

Installation
  1. Install ScriptHookV
  2. Copy the *.asi and the LeFixSpeedo folder into the Grand Theft Auto V main folder.
  3. Please read the ingame mod info.
  4. Set the settings to your preferences:
    -Using the mod menu (Recommended, by default F10).
    -Manually by editing the .ini files (for advanced users).
Changelog
v1.2.4b
fixed memory addresses for latest GTA V update
v1.2.4a
bugfix: fuel hud stayed visible after driving car once, even after entering another vehicle without fuel
v1.2.4
-reworked gear display for ikt transmission mod
(better flickering, top gear slightly red, correct when engine is off)
-mod menu info is now always visible (can be disabled)
v1.2.3e
-bugfix: GTA V update changed rpm/gear addresses
-better compatibility with ikt's Manual Transmission Mod (gear display matches 100%)
-handbrake notification as 'N' on gear display togglable now
v1.2.3d
-bugfix: speedo disappeared while driving with mouse
-bugfix: improved characterwheel detection (no more bugs using dpad)
v1.2.3c
-changed name of fuel hud pictures
(now matches the decorator name)
-fuel hud will be visible if at least one of the three decorators is modified by an external mod
v1.2.3b
-minor bugfix: 'Use high speedo' isn't saved correctly
v1.2.3a
-bugfix: didn't fade out hud when using mobile phone in helis/planes
-bugfix: HUD fades out with ikt's update of 'Manual Transmission' mod installed.
-Removed fuel setting. Auto-detects if external fuel mod shares its data.
v1.2.3
-bugfix: didn't switched to next speedo background if max velocity is reached
-added shift up/down indicator (pictures and flashing gear/leds)
-got rid of gameversion setting
v1.2.2c
-bugfix: acceleration time not displayed properly
(digit gap was dependent of screen resolution)
-bugfix: gear showed desired gear
(almost always same value as current gear)
v1.2.2b
-gear isn't an estimation anymore
v1.2.2a
-updated to latest version of ScriptHookV
-added fuel test.asi and source
-bugfix: only deacceleration test worked
v1.2.2
-added acceleration test
v1.2.1a
bugfix: white damage indicator
v1.2.1
-added support of Smart Fuel Mod V [Pertamina] Mod
https://www.gta5-mods.com/scripts/smart-fuel-mod-all-in-1
v1.2.0b
-added three real life brands as example
-changed size of brand images (same as speedo background now)
v1.2.0a
-more brand logos
-bugfix: couldn't navigate in 'Toggle HUD'
-bugfix: wrong needle rotation
-changed default background of muscle cars back to 180mph
v1.2.0
-brand logo added
-cleaned mod menu
-finished reorganisation of inis
-better support for vehicle mods

Contact Me
For bug reports: gaming@die-optimisten.net

Thanks to
Alexander Blade,
machine4578,
XMOD and
ikt
First Uploaded: July 08, 2015
Last Updated: December 18, 2016
Last Downloaded: 7 minutes ago
180,672

Sponsored Link

820 Comments

  • Df86ab tubeguyburns
    LeFix
    Pinned Comment

    Updated the memory addresses which have been changed by the latest GTA V update.

    Thanks to @ikt for providing the address information (again) and @machine4578 who tested it.

    December 18, 2016
  • Default

    @LeFix After Installation When i Enter Into a Car Speedometer Is visible but When I Accelerate The Speedometer Disappers.

    January 16, 2017
  • Default

    Works great, although there is a glitch where Gear HUD was stuck in Reverse or Neutral even while in Drive. Gonna try reinstalling...

    January 21, 2017
  • Default

    Works after reinstalling. Fuel mod also works great.

    I was probably messing around in the .ini settings, lol...

    January 21, 2017
  • F02d23 youtube channel icon

    Excellent work on this mod thank you! I use this mod full time now and it is featured in my YouTube series Daily Ped Life: https://www.youtube.com/playlist?list=PLNZ71UwsLsDAj9-g3JAVGO6m5g4FP80v0 5 star rating from me!

    January 28, 2017
  • Heists

    RPM's are not accurate, everything else is pretty good.

    February 05, 2017
  • Df86ab tubeguyburns
    LeFix

    @tonywashere
    Well they are as accurate as you want them to be. The rpm value is betwen 0.0 and 1.0 for ALL vehicles, it's just the dashboard textures which is different. (Which cannot be read properely by the code)
    I don't play GTA V for months now, so the "max rpm" values I set up once are not exact for all cars but should be near the values displayed on the dashboard and cars from DLCs aren't listed yet. But it doesn't bother me in the slightest.

    Anyone can correct wrong values in the settingsMaxRpm.ini (!) file and add DLC cars easily!
    There's no speedometer mod even trying to show the "correct" rpm values for each specific car except mine. If you expect correct values, you have to do it yourself.

    The brand logo feature behaves the same way. I listed the brands of the majority of cars and provided so many brand logos with improved quality. Anyone can copmplete the list or at least add some missing cars.

    It's not my problem if the community expects something but isn't willing to help and share few lines/files. Once again, use the possibilities which are given by the mod before you start to complain.

    February 07, 2017
  • Default

    @LeFix Regarding the brands, this does not seem to work with the add on cars.

    I would like to be able to add individual logos for my add on cars without any restrictions, and leaving the GTA cars with their original logos. Any chance this will be added?

    February 13, 2017
  • Df86ab tubeguyburns
    LeFix

    @nkjellman Don't add-on cars have their unique livery name? You can add new brand names and new images without changing existing brands, but it uses the livery name to determine the vehicle brand, so different vehicles with same liveryname will have same brand.

    February 13, 2017
  • Default

    @LeFix I will have to test more vehicles.

    February 13, 2017
  • Default

    @LeFix None seem to work. But what do you mean by livery name? I thought it went by vehicle model. Not every car has a livery (paint job). Are you refering to the GameName parameter or the VehicleMake parameter in the vehicles.meta?

    February 14, 2017
  • Df86ab tubeguyburns
    LeFix

    You can see the liveryname as subtitle, when you choose the car brand setting. (in mod menu)
    Please check it and tell me.

    February 15, 2017
  • E2973a r

    Been using this for month and its awesome. I just don´t get how to fix the "maxed out rpm thing" @LeFix can you help me out? Right now i just removed it from display, but i liked it a lot :)

    February 15, 2017
  • Default

    Rpm is stuck in reverse reinstalling didn't help

    10 days ago
  • Df86ab tubeguyburns
    LeFix

    @Jacknife2014 Rpm stuck in reverse? Do you mean the current gear which is displayed or the rpm needle?
    @RalFingerLP Which gameversion do you use? If it's up to date it should work fine.

    10 days ago
  • E2973a r

    @LeFix it is up to date, I don´t know why this is happening

    9 days ago
  • Default
    9 days ago
  • Df86ab tubeguyburns
    LeFix

    @RalFingerLP @Jacknife2014
    I'm sorry, but I have currently no time to search for bugs which occurs for so few people. I think it's the wrong memory address but many people playing with the same gameversion can use it without any problems...

    9 days ago
  • E2973a r

    @LeFix thanks for your reply. Take your time. Love to use it :)

    9 days ago
  • Default

    That's fine! Still an awesome mod along with the fuel mod!

    8 days ago
  • Default

    Can you use it online?

    2 days ago
Join the conversation! Log In or register for an account to be able to comment.